• deus ex machina

      The cavity's depth has nothing to do with pickup height unless it's a direct-mounted pickup.

      This just means that the bridge isn't very low-profile. You could just cut the springs that go around the pickup screws to a shorter lenght so that you could raise the pickups closer to the strings.

      • sean106OCD

        Just put them in my Edwards LPC today and set it up for D/Drop C (for band tuning). Sounds great.

      • Geetarguy70

        The cavity's depth has nothing to do with pickup height unless it's a direct-mounted pickup.

        This just means that the bridge isn't very low-profile. You could just cut the springs that go around the pickup screws to a shorter lenght so that you could raise the pickups closer to the strings.

        I need to experiment. The Snakebyte pups came with shorter springs but when I put them in with the JH set the bridge pup wobbled a lot so I put the springs in that came in the JH. Maybe needs to come up just a touch

    • deus ex machina

      That looks killer, Sean! How are you digging the Edwards tone-wise?... regardless of the pickups in it, I mean.

      • sean106OCD

        That looks killer, Sean! How are you digging the Edwards tone-wise?... regardless of the pickups in it, I mean.

        Really baffled how well it sounded and was crafted before the pup's. Makes me want a ED Explorer but heard they are still not so good. With the 60/81 it sounded real nice and the JH set takes it to the next level. Very thick sounding, full and frankly like an LPC I used to have with EMG's. I was amazed when I took all the strings off. The fretboard looked like glass and the inlays looked top notch. Highly recommend this model. The stock pup's were OK. Nothing great but not bad.

    • Niklas L.

      Looks great Sean! What Edwards model is that?

    • deus ex machina

      E-LP-92CD, right, Sean?

      I really want one of those myself. Been wanting one for a LOOOOOONG time. I have heard almost nothing negative about those. Thanks for the mini-review. :)

    • ammar

      HHNNNNGGGGG Holy mother of GAS. 2012, meet my new guitar.

      • sean106OCD

        HHNNNNGGGGG Holy mother of GAS. 2012, meet my new guitar.

        Do it!

        I was so GASing last night on that Blue Eclipse that was posted, as I could have went 10 minutes over and bought it (well I did call them but my main connect who gets me deals was not in today 8o8o) but then I thought about it. For less I can get a Edwards LPC or other LP and EMG it out if I wanted.

        Edwardo's Les Pauls on the Bay :)

    • Geetarguy70

      Got my eye on the white LPC!

    • deus ex machina

      Killer pics, Sean! :D

      Thanks for the review.

    • dodgethis

      Just got a set of these pickups and installed them in my Eclipse FT. However, I am having issues with the neck pickup. On my JVM's Crunch Red channel, the neck pickup plays very clean, as though I am running in on my Clean Green. Added to that, running the neck on my Clean Green yields almost no sound at all but the bridge sounds nice and clean. All my wiring is done as stated in the instructions.

      Did anyone else encounter this problem?

    • Geetarguy70

      Dude my neck pick up sounds amazing no issues. I just lowered it as it is hotter than the 60 but I found a great spot and it's working great. First live show tonight with them so I will post tomorrow how it went. Hope you find the prob quick!

    • dodgethis

      Did some KISS trouble shooting by hooking the neck pickup to the bridge controls. Lo and behold, it sounds as it should! I'm guessing a defective pot or wire!

      Edit: Pot checks out at 24.6kohms.

      • Geetarguy70

        Did some KISS trouble shooting by hooking the neck pickup to the bridge controls. Lo and behold, it sounds as it should! I'm guessing a defective pot or wire!

        Edit: Pot checks out at 24.6kohms.

        Awesome! how are you liking the sound?

    • dodgethis

      I haven't gotten to getting the sound of the neck yet. I'm still not done fixing this problem. It's just that I have eliminated the issue of the pickup itself not being defective. It's something in the circuit that's causing this problem.

      I read up that the pickup not having an adequete power supple can lean to this issue. However, when I swapped the connector over to the bridge volume pot, that's the only thing I change. So, I think the power is out as well since the red cable in the pickup buss is still in the same place.

      DEAR GOD, WHY MUST THIS HAPPEN TO ME.

      On the same note, the bridge sounds awesome. It sounds way better than the EMG81 I had in there, even with an 18V harness.

    • cecilbag

      They really do look great

    • dodgethis

      Thanks for the compliments. The black nickel doesn't look out of place at all. I will be taking more pictures once the problem's resolved.

      Passed on the guitar with the pups to the dealer to troubleshoot the issue. The problem still persists even after I redid all the wiring. And yes, I did change around the wires to make sure the wires weren't the issue.

      Now I wait...

    • deus ex machina

      Don't the pickups come with everything solderless?

      If they didn't, didn't your eclipse come with EMG's already? Wasn't it a matter of simply unplugging the pickups and plugging in the new ones? :confused:

    • dodgethis

      I swapped out everything for the solderless stuff that came with the JH set. Hindsight, 20/20, etc.


    Cancel